Начало работы с Arduino

← Мотор | Оглавление


  1. Скачайте Arduino IDE с официального сайта
  2. Если у вас Windows и Arduino IDE из zip-файла, установите драйверы из папки drivers
  3. Подключите Arduino к компьютеру через USB
  4. Запустите Arduino IDE
  5. В «Tools → Board» выберите модель вашей платы
  6. В «Tools → Serial Port» выберите порт, куда она подключена
  7. Пишите программу или загружайте готовый пример из «File → Examples»
  8. Жмите «Upload» на панели инструментов для прошивки платы!

Перепрошивать плату можно сколько угодно раз. Программа сохраняется после обесточивания платы.

Внешний вид Arduino IDE

Если прошивка не удаётся

Проверьте, что:

  • Плата получает питание, горит светодиод «ON»
  • Драйверы под Windows установились корректно, и в диспетчере устройств вы видите устройство «Arduino Uno»
  • Вы выбрали правильную модель платы и правильный порт (пункты 5 и 6)
  • USB-кабель исправен

← Мотор | Оглавление